思科交換機常用命令及配置

switch> 用戶模式

1:進入特權模式enable

switch> enable

switch#

2:進入全局配置模式configure terminal

switch> enable

switch#configure terminal

switch(conf)#

3:交換機命名hostname name 以cisco001 為例

switch> enable

switch#c onfigure terminal

switch(conf)#hostname cisco001

cisco001(conf)#

4:配置使能口令(未加密)enable password cisco 以cisco 為例

switch> enable

switch#configure terminal

cisco001(conf)# enable password cisco

5:配置使能密碼(加密)enable secret ciscolab 以cicsolab 為例

switch> enable

switch#configure terminal

switch(conf)# enable secret ciscolab

6:設置虛擬區域網vlan 1 interface vlan 1

switch> enable

switch#configure terminal

switch(conf)# interface vlan 1

switch(conf)# ip address 192.168.1.1 255.255.255.0 配置交換機埠ip 和子網掩碼

switch (conf-if)#no shut 激活埠

switch (conf-if)#exit

switch (conf)#ip default-gateway 192.168.254 設置網關地址

7:進入交換機某一埠interface fastehernet 0/17 以17 埠為例

switch> enable

switch#configure terminal

switch(conf)# interface fastehernet 0/17

switch(conf-if)#

8:查看命令show

switch> enable

switch# show version 察看系統中的所有版本信息

show interface vlan 1 查看交換機有關ip 協議的配置信息

show running-configure 查看交換機當前起作用的配置信息

show interface fastethernet 0/1 察看交換機1 接口具體配置和統計信息

show mac-address-table 查看mac 地址表

9:交換機恢復出廠默認恢復命令

switch> enable

switch# erase startup-configure

switch# reload

10:交換機的密碼恢復

拔下交換機電源線。

用手按著交換機的MODE 鍵,插上電源線

在switch:後執行flash_ini 命令:switch: flash_ini

查看flash 中的文件: switch: dir flash:

把「config.text」文件改名為「config.old」: switch: rename flash: config.text flash: config.old

執行boot: switch: boot

交換機進入是否進入配置的對話,執行no :

進入特權模式察看flash 里的文件: show flash :

把「config.old」文件改名為「config.text」: switch: rename flash: config.old flash: config.text

把「 config.text 」 拷入系統的「 running-configure 」: copy flash: config.text system :

running-configure

重新設置密碼並保存。

11.交換機telnet 遠程登錄設置:

switch>en

switch#configure terminal

swich(conf)#enable password cisco 以cisco 為特權模式密碼

swich(conf)#interface vlan 1 以vlan 1埠作為遠程登錄的接口,其他埠亦可

swich(conf-if)#ip address 192.168.1.1 255.255.255.0

swich(conf-if)#no shut

swich(conf-if)#exit

swich(conf)line vty 0 4 設置0-4 個用戶可以telnet 遠程登陸

swich(conf-line)#login

swich(conf-line)#password 123456

12.交換機ssh遠程登錄設置:

a.設定一個非默認的hostname

Switch(config)#hostname cisco

b.配置域名:

cisco(config)#ip domain-name test

c.指定加密長度:

cisco(config)#crypto key generate rsa

How many bits in the modulus [512]: 1024

% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

d.將vty線路下的登錄方式改為 ssh

cisco(config)#line vty 0 4

cisco(config-line)#transport in ssh

13.配置vtp同步

說明:VTP(VLAN Trunking Protocol):是VLAN中繼協議,它是思科私有協議。作用是同步各個交換機之間的VLAN信息。

要使用VTP,首先必須建立一個VTP管理域,在同一個管理域中交換機共享vlan信息,並且一個交換機只能參加一個管理域,交換機之間使用trunk口連接。

方法/步驟

配置實例:

要求配置switch0、switch1、switch2實現vlan共享,並在switch0上添加、刪除vlan,查看switch1、switch2是否同步

配置命令參考:

Switch0:

switch0(config)#vtp domain test  配置vtp 管理域

switch0(config)#vtp password 123 配置vtp密碼

Switch0(config)#interface fa0/1   配置接口模式為trunk

Switch0(config-if)#switchport mode trunk

switch0(config)#int fa0/2

switch0(config-if)#switchport mode trunk

switch1:

switch1(config)#vtp domain test  配置vtp 管理域

switch1(config)#vtp password 123 配置vtp密碼

Switch1(config)#interface fa0/1   配置接口模式為trunk

Switch1(config-if)#switchport mode trunk

switch2:

switch2(config)#vtp domain test  配置vtp 管理域

switch2(config)#vtp password 123 配置vtp密碼

Switch2(config)#interface fa0/1   配置接口模式為trunk

Switch2(config-if)#switchport mode trunk

在switch0 上添加vlan2,vlan3 :

switch0(config)#vlan 2

switch0(config-vlan)#exit

switch0(config)#vlan 3

switch0(config-vlan)#exit

switch0(config)#

本文內容整理自網絡, 文中所有觀點看法不代表淘大白的立場